Talk:Infantry (Long War)

From UFOpaedia
Jump to: navigation, search

Lock'n'Load bugged?

I have two Infantry soldiers with Lock'n'Load and both end their turn when I reload the main weapon. Is the ability bugged in general (e.g. for other classes, too), is it only for the Infantry class or did I something wrong? I use Battle Rifles for the Infantry, maybe that is the reason? I am not sure if the other part of the ability works (the additional magazin capacity). I installed the mod three days ago from the nexus page, so it should be the current version. --ZDW (talk) 09:05, 16 July 2014 (EDT)

Works for me, though I've not tried it with Battle Rifles. Are you reloading as first action? It still uses an action to reload, but you can fire or move afterwards. Binkyuk (talk) 09:15, 16 July 2014 (EDT)
Tried it with a Laser Rifle now: Same problem. I use Reload as first action in the round, the soldier reloads and ends his turn.
Edit: It works correctly for my sniper, he uses a common sniper rifle.
--ZDW (talk) 10:35, 16 July 2014 (EDT)
This sounds like a bug since the description clearly states that you can reload your weapon as the first action without ending the turn. It's better to report it to the relevant thread on the Nexusmods forums and indicate the LW version that you are using. Hobbes (talk) 10:45, 16 July 2014 (EDT)
Ok, I reported it as bug.--ZDW (talk) 13:44, 16 July 2014 (EDT)