Talk:Thermal Shok Launcher

From UFOpaedia
Jump to: navigation, search

Glitchy TSL Behaviour in CE

From time-to-time I've noticed that if an alien armed with a TSL makes a reaction shot it will often fire as if it were auto-fire ie: 3 shots. The weird thing is that only the 1st shot appears to be a shok bomb, the other two have the same appearance and firing sound, but thier explosion anim. and sounds are from the 'small' explosives like GC HE rounds. They also seem to do no damage at all.

I've seen this oddness many times from aliens with TSLs, but never from my troops. Its not really a serious thing as it doesn't make any real difference to how things play out, but its definatley a 'WTF?' moment.

Tifi 06:19, 4 May 2008 (PDT)

By any chance, was the alien reaction shot taken at a range of 3 or less? -- Zaimoni 11:58, 4 May 2008 (CDT)
Nay. The range was more like 15-ish, almost a whole screen. It was at the 1st stage of an Artefact Site from an Aquatard camping in the 'exit' room if that helps any... Tifi 13:21, 6 May 2008 (PDT)
I've noticed that TFTD has a tendancy to glitch some of its weapons at odd times during the alien movement phase. Some players have seen an alien fire the sonic blasta rifle repeatedly in one turn (although I often see this associated with Max's ET version - it could very well happen with the plain vanilla version as well). I've seen a reaction fired hydrojet cannon rip holes through an X-Com base wall - with no sound or scratchy distorted sound effects (reaction fire allows this gun to fire on land - but it's not strong enough to do that). On later turns it didn't follow the same pattern. Then again all the text graphics started to get messed up, and the game promptly crashed shortly afterwards.
Unless it happens often, I'd probably just chalk it up as a one-off glitch. - NKF 22:32, 6 May 2008 (PDT)